Buy Now
QuantumXl 2013

System Requirements


Quantum XL System Requirements

Quantum XL Box Shot

Quantum XL runs on Microsoft Excel 2000, Excel XP (2002), Excel 2003, Excel 2007, Excel 2010, Excel 2013 and Excel 2016; therefore, you must have Excel 2000 or later installed on your computer to run Quantum XL. You should also be running Windows XP, Vista,  Windows 7, Windows 8 or Windows 10. Quantum XL is not compatible with non-Windows operating systems.



compatible

To determine your version of Microsoft Excel, select "Help" - "About Microsoft Excel" from the Excel menu. The "About Microsoft Excel" dialog box will appear with the version of Excel at the top.